zondag 15 december 2013

Twee issues bij SharePoint 2013 op Windows 8 afgespeeld in een VMWare Player op een server met Hyper-V...

Je zou het maar willen... SharePoint 2013 op Windows 8 afspelen in een VMWare Player op een server met Hyper-V.

Ja, dat kan gebeuren als je een voorbereid VMWare image zonder al te veel moeite wilt gebruiken.

Toch twee issues tegengekomen waarbij, na wat zoeken op internet, ik niet de enige ben die dit is tegengekomen (toch enigszins een geruststelling).

Voorbereiding bestond uit het kopiƫren van het image naar mijn server en deze in de (gratis) VMWare Player proberen af te spelen.

Resultaat: fatal error waarin werd verwezen naar een probleem in het geheugen: "No-Execute Memory Protection option enabled on your motherboard". En dat mijn pc maar moest worden herstart. Niet doen, dat helpt niets, het probleem zit 'm in een instelling in je BIOS (de "No-Execute Memory Protection" van de host machine, niet van de virtuele machine). De instelling heette in mijn BIOS overigens anders, namelijk: "X-Bit".

Nieuwe poging: nu klaagt VMWare dat 't niet wil samenwerken met Hyper-V en dat ik de Hyper-V rol maar moet verwijderen van mijn server (kinderachtig hoor!). Nu was ik dat niet van plan, en in zo'n geval ga ik op zoek naar een truuk: het tijdelijk uitzetten van de Hyper-V rol:

// to disable hyper-v
bcdedit /set hypervisorlaunchtype off

En om 'm weer aan te zetten:

// to enable hyper-v
bcdedit /set hypervisorlaunchtype auto

Geen opmerkingen:

Een reactie plaatsen